"МВТУ": Программый комплекс для моделирования и исследования объектов и систем

Федосов Б.Т.

Приятное знакомство:
"МВТУ"
программный комплекс для моделирования и исследования объектов и систем

Предлагаемые вашему вниманию методические указания предназначены для быстрого знакомства с назначением программного комплекса "МВТУ"и приемами работы с ним. Это введение позволит инженеру, студенту или аспиранту оценить потенциальные возможности ПК "МВТУ" при решении учебных, технических и научных задач и принять решение о целесообразности его использования в работе. Рассмотрение будет проведено на основе ограниченного варианта программы, свежую версию которой можно получить на сайтах [1, 2, 3]. Установка и запуск программы осуществляются традиционно и не встречают никаких сложностей.

Настоящее рассмотрение комплекса "МВТУ" ориентируется на его применение в решении задач теории автоматического управления (ТАУ), хотя область применения ПК "МВТУ" может быть значительно шире. Углубленное изучение возможностей программы может быть проведено с помощью обстоятельных поясняющих материалов и примеров, прилагаемых к ПК "МВТУ".

Программный комплекс "МВТУ" (моделирование всевозможных технических устройств, объектов и систем) разработан в МГТУ им. Н.Э.Баумана коллективом авторов под руководством доцента О.С. Козлова и предназначен для моделирования и исследований проектируемых и действующих систем и объектов. Комплекс позволяет моделировать объекты широкого спектра сложности: от простейших элементов систем управления до систем управления ядерными реакторами, для чего собственно он и создавался. В последнем случае ПК "МВТУ" позволяет создавать виртуальные тренажеры даже для тренировки операторов атомных электростанций.

Достоинства программного комплекса "МВТУ":

  • русскоязычный графический интерфейс. Это единственная программа в своем классе, «говорящая» по-русски;
  • простота построения моделей, управления их работой, проведения исследований и получения их результатов;
  • возможность при желании обойтись при построении моделей без записи программного кода. В то же время, в случае необходимости, комплекс позволяет воспользоваться мощным математическим аппаратом;
  • относительно высокое быстродействие, позволяющее моделировать многие системы в реальном и ускоренном масштабах времени;
  • возможность создания анимации, позволяющей воссоздавать внешний облик работающих и исследуемых объектов и измерительных приборов, что увеличивает наглядность модели.

    Советы по работе с данным пособием

    ПК "МВТУ", как и любая программа, имеющая графический интерфейс, требует некоторого периода адаптации, привыкания к внешнему виду панелей и способам работы. После запоминания назначения основных инструментов управления новичок начинает чувствовать комфорт, о создании которого позаботились разработчики.

    Для удобства знакомства с программой, используя данное пособие, целесообразно окна ПК "МВТУ" поместить в верхней части экрана, а окно с лабораторной работой расположить в нижней части экрана, примерно вот так

    Расположение окон ПК "МВТУ" и методического пособия по его изучению.

    В этом случае переход от пособия к изучаемому комплексу и обратно упрощается. Разрешение экрана полезно установить в 800х600 или выше.

    Для экономии места некоторые рисунки выполнены с применением анимации, для ee запуска может потребоваться щелкнуть по кнопке Обновить браузера (окна, в котором вы читаете этот текст).

    Федосов Б.Т.

    Лабораторная работа №1

    Знакомство с интерфейсом и
    принципами построения моделей в
    программном комплексе
    "МВТУ"

    Содержание

    1. Цель и задачи работы
    2. Общее представление о ПК "МВТУ"
      • 2.1. Принципы моделирования в ПК "МВТУ"
      • 2.2. Интерфейс ПК "МВТУ"
      • 2.3. Основные элементы модели
        • 2.3.1. Генераторы сигналов
        • 2.3.2. Элементы линейных систем
        • 2.3.3. Индикаторы и регистраторы
        • 2.3.4. Соединительные линии
      • 2.4. Простая модель
      • 2.5. Поясняющие надписи
    3. Задание к работе
      • 3.1. Запуск ПК "МВТУ"
      • 3.2. Исследование апериодического звена
        • 3.2.1. Создание нового проекта
        • 3.2.2. Построение модели
        • 3.2.3. Задание свойств блока апериодического звена
        • 3.2.4. Запуск программы на счет
        • 3.2.5. Исследование свойств апериодического звена
      • 3.3. Сохранение проекта.
      • 3.4. Отчет о лабораторной работе
    • Заключение
    • Контрольные вопросы
    • Литература и ссылки
    • Приложение

    1. Цели и задачи работы

    Цель работы: знакомство с принципами построения моделей, с интерфейсом ПК "МВТУ" и приобретение элементарных навыков работы с ним.

    Задачи работы:

    • ознакомление с основной панелью программы;
    • изучение основных элементов, позволяющих создавать модель и управлять ею;
    • создание и исследование простейшей виртуальной модели.

    2. Общее представление о ПК "МВТУ"

    2.1. Принципы моделирования в ПК "МВТУ"

    Принцип моделирования в ПК "МВТУ" состоит в создании и исследовании виртуального аналога реальной системы – модели. Модель функционирует в соответствии с теми же уравнениями, что и моделируемая система. При моделировании не обязательно записывать эти уравнения в явном виде, об этом позаботится программа. Модель составляется пользователем в специальном окне программы соединением отдельных виртуальных блоков, соответствующих элементам реальной системы.

    Виртуальные блоки условно внешне представляются на рабочем пространстве окна модели прямоугольниками, т.е. они видимы исследователю, имеют входы и (или) выходы и функционируют в соответствии с определенными уравнениями, алгоритм решения которых реализуется в цифровом виде. Под функционированием виртуального блока понимается то, что он реагирует на виртуальные воздействия (функции времени), подаваемые другими блоками на его вход, определенным изменением величины выходного сигнала.

    Взаимодействие между блоками условно отображается на рабочем пространстве окна модели в виде соединительных линий. Соединительные линии в ПК "МВТУ", как и блоки, являются однонаправленными, передают виртуальные воздействия только в одном направлении. Другими словами, последующие блоки и звенья не влияют на работу предыдущих. Для модели электрической цепи, например, это означает, что выходное сопротивление предыдущего блока значительно меньше входного сопротивления последующего блока. Сигналы, действующие в модели можно наблюдать и регистрировать виртуальными индикаторами. Для этого программа создает специальные окна с временными, частотными графиками, фазовыми портретами и др.

    Параметры и характеристики блоков, как и структуру схемы модеи, исследователь может изменять. Программа предоставляет возможность вычислять различные характеристики построенных моделей, в частности амплитудно-частотные, анализируя которые можно глубоко изучить свойства модели, а, следовательно, и моделируемой реальной системы.

    Модель ПК "МВТУ" может быть сохранена в виде отдельного файла и, при необходимости, открыта вновь.

    2.2. Интерфейс ПК "МВТУ"

    Интерфейс программы это совокупность средств, позволяющих человеку общаться с ней:

    • вводить и получать данные,
    • подавать управляющие воздействия и наблюдать реакцию на них программы,
    • контролировать ход ее выполнения и т.п.

    Программный комплекс "МВТУ" использует развитой графический интерфейс, позволяющий основную часть создания модели выполнить с помощью мыши, а параметры элементов ввести с клавиатуры. Интерфейс ПК "МВТУ" состоит из основной панели (главного окна), имеющей меню и ряд кнопок управления, воспринимающих щелчки копок мыши, и совокупности окон, в которых строится модель и наблюдаются результаты ее работы.

    Основная панель – главное окно программы, появляющееся в верхней части экрана после запуска ПК "МВТУ" (рис.1).

    Рис. 1. Основная панель ПК ""МВТУ"". Выделены кнопка Пуск (Продолжить расчет) и три важных вкладки Палитры с наборами элементов (виртуальных блоков), которые будут использоваться при моделировании: Источники сигналов (генераторы) – вкладка открыта, Данные (индикаторы и регистраторы) и Динамические блоки (элементы линейных систем и систем в целом).

    Верхняя часть главного окна – панель управления. Она содержит меню и кнопки управления и настройки. Нижняя часть главного окна это т.н. Палитра блоков – структурированный набор вкладок, содержащих образцы моделей различных элементов, которые могут быть вынесены в окно модели (схемное окно). При необходимости палитра блоков может быть перенесена на другое место или вовсе удалена с экрана для освобождения места для схемы модели, индикаторов и др. На рис.1 выделены три важных набора элементарных блоков: генераторы, индикаторы и модели линейных элементов, которые позволяют строить модели линейных систем и объектов и будут подробнее рассмотрены ниже. Кнопки в правой верхней части палитры позволяют просматривать и другие вкладки, с наборами соответствующих блоков, в частности, вкладку Анимация .

    2.3. Основные элементы модели

    2.3.1. Генераторы сигналов

    Генераторы сигналов размещены на вкладке Источники основной панели (рис.2):

    Рис. 2. Часть набора виртуальных генераторов, имеющихся на вкладке Источники. Важными источниками сигналов являются генераторы ступенчатого и синусоидального сигналов. Кнопка со стрелкой Вправо позволяет посмотреть и другие источники сигналов.

    2.3.2. Элементы линейных систем

    Блоки, моделирующие элементы линейных систем и объектов различной сложности помещены на вкладке Динамические (рис.3):

    Рис. 3. На вкладке Динамические блоки помещены образцы моделей элементов линейных систем. Для начала, обратим внимание на интегратор, апериодическое и колебательное звенья.

    2.3.3. Индикаторы и регистраторы

    Рис. 4. Важный регистратор – виртуальный осциллограф (блок Временной график).

    Примечание: программа позволяет создавать и собственные варианты индикаторов с помощью инструментов, расположенных на вкладке Анимация (в правой части Палитры).

    2.3.4. Соединительные линии

    Соединительные линии позволяют отобразить взаимодействие между отдельными элементами реальной системы. В ПК "МВТУ" соединительные линии однонаправленные: они передают виртуальные сигналы с выходов блоков на их входы. Это означает, что в моделируемых системах последующие блоки не должны влиять на работу предыдущих блоков. Такое требование следует выполнить при составлении функциональной схемы моделируемой системы, должным образом выделяя ее функциональные элементы. Линии проводятся от одного блока модели к другому с помощью мыши. Пример соединительных линий можно видеть в левом нижнем окне модели рис. 5.

    2.4. Простая модель

    На рис.5 показана простая модель, состоящая всего из одного блока – апериодического звена и результаты его исследования, состоявшего в определении реакции этого звена на ступенчатое воздействие, так называемой переходной функции.

    Рис. 5. Определение переходной функции апериодического звена. На левое нижнее окно модели вынесены генератор ступенчатого сигнала, апериодическое звено, осциллограф и соединены друг с другом. При запуске модели, нажатием на кнопку Пуск (Продолжить расчет CTRL+ F9) - бегущий человечек, на осциллографе появляется график реакции звена на ступенчатое воздействие – его переходная функция.

    Виртуальный генератор в нулевой момент времени подает на вход апериодического звена ступенчатое единичное воздействие, на которое звено откликается все замедляющимся ростом выходного сигнала. Виртуальный осциллограф позволяет увидеть изменение выходного сигнала звена с течением времени и проанализировать его.

    2.5. Поясняющие надписи.

    Сопровождение модели поясняющими надписями позволяет облегчить ее восприятие и работу с ней. В пояснении нужно указать кто, когда и какую модель создал. В "МВТУ" можно создавать пояснения двух видов: заметку, текст которой виден вместе с блоками модели и комментарий, текст которого открывается в отдельном окне, при двукратном щелчке по квадратному блоку со знаком вопроса. Блоки заметки (без обозначения) и комментария (квадрат со знаком вопроса) «затерялись» в правой части вкладки Субструктуры (рис.6):

    Рис.6. Блоки заметка и комментарий выносятся на рабочее пространство окна модели с вкладки Субструктуры. Внизу показано окно просмотра и редактирования комментария.

    3. Задание к работе

    3.1. Запуск программы

    С разрешения преподавателя запустить программный комплекс "МВТУ" двойным щелчком по иконке на рабочем столе, или Пуск – Программы – МВТУ 3.0 – МВТУ 3.0, или по файлу MBTY.exe из папки C:\Program Files\MBTY 3.0\Bin, куда была установлена программа. В верхней части экрана появится основное окно ПК "МВТУ" (рис.1).

    3.2. Исследование апериодического звена

    Исследовать апериодическое звено, построив модель рис. 5. Для этого:

    3.2.1. Создать новый проект:

    Выбрать в главном меню Файл -> Создать или щелкнуть по соответствующей иконке основной панели (рис.7). Ниже основного окна появится окно модели C:\Program Files\MBTY 3.0\Projects\Noname.mrj

    Рис.7 (анимация). Окно модели нового проекта, запускаемого кнопкой Новый, и вынесение генератора ступенчатого сигнала на рабочее пространство окна.

    3.2.2. Построить модель

    Поместить на рабочее пространство окна модели блоки генератора ступенчатого сигнала с вкладки Источники, апериодического звена с вкладки Динамические, осциллографа (Временной график) с вкладки Данные. Для помещения блока следует щелкнуть по его обозначению на вкладке палитры, перенести курсор на нужное место рабочего пространства окна модели и вновь щелкнуть левой кнопкой.

    Выровнять расположение блоков и соединить их. Соединение блоков требует определенной сноровки и навыка. Для соединения нужно щелкать на выходе одного блока, курсор принимает вид прицела, и при отпущенной кнопке мыши перемещать курсор к входу другого блока, где вновь щелкать левой кнопкой (рис.8). Если соединительная линия не удалась, то ее можно удалить, щелкнув по ней правой клавишей и выбрав пункт меню Удалить линию в связи.

    Рис.8 (анимация). Размещение блоков в окне модели и соединение их. Для приостановки анимации следует щелкнуть по кнопке Стоп браузера, а для продолжения – по кнопке Обновить.

    Дважды щелкнуть по блоку осциллографа (График), его появившееся окно переместить на свободное место вправо и подравнять размеры и расположение окон (рис. 9).

    Рис.9. Размещение окна виртуального осциллографа.

    3.2.3. Задание свойств блока апериодического звена

    Напомним, что передаточная функция апериодического звена имеет вид [3]:

    где: k – коэффициент усиления звена;

    T – постоянная времени звена.

    Щелкнуть правой клавишей по апериодическому звену в окне модели, в появившемся меню выбрать Свойства. В появившемся окне ввести значение коэффициента усиления 2.3 и значение постоянной времени звена 0.9 сек (рис. 10).

    Рис.10. Задание коэффициента усиления и постоянной времени исследуемого апериодического звена.

    Щелкнуть по кнопке Да.

    3.2.4. Запуск программы на счет.

    Щелкнуть по кнопке Пуск (Продолжить расчет Ctrl+F9) с изображением бегущего человечка на основной панели (рис.9). Моделирование запущено.

    На вход апериодического звена будет подан ступенчатый виртуальный сигнал, на который блок отреагирует постепенным, все более медленным возрастанием сигнала до его устанавливающегося значения. Отметим, что появится окно с пугающим предупреждением о том, что заданная точность не обеспечивается. Но это предупреждение относится только к первому шагу интегрирования, поэтому его окно следует просто закрыть и можно анализировать полученную переходную характеристику (рис.5).

    3.2.5. Исследование свойств апериодического звена

    Переходная функция апериодического звена имеет вид [3]:

    Обратим внимание, что переходная функция апериодического звена с течением времени стремится к значению его коэффициента усиления, а касательная, проведенная в нулевой момент времени к кривой переходного процесса, пересекает уровень стабилизации сигнала в момент времени, равный постоянной времени звена. Это позволяет определять параметры апериодического звена по его известной переходной характеристике.

    Проверьте это утверждение, меняя коэффициент усиления и постоянную времени звена. Результаты проверки сгруппируйте в таблице.

    Если у вас еще осталось время, щелкните правой кнопкой по графику, в выпавшем меню выберете Свойства и поэкспериментируйте с ними: дайте содержательное название графику: Переходная характеристика, измените цвет и толщину линии графика, название переменной по оси ординат замените на более содержательное: Выходной сигнал (между словами нажать Enter).

    Щелкните правой кнопкой по блоку осциллографа в окне модели, в выпавшем меню выберете Свойства, в появившемся окне перейдите на вкладку Общие и задайте в нижнем окне заголовок (название) блока: Осциллограф, который появится под блоком при щелчке по кнопке Да.

    3.3. Сохранение проекта.

    В меню Файл выбрать Сохранить как, в появившемся окне указать путь к своей личной папке и, назвав проект Perech_Ap_Zv.mrj, сохранить его.

    Кроме собственно проекта полезно сохранять и снимки экрана, с тем, чтобы прикладывать их к отчету. Для получения снимка следует нажать клавишу Print Screen клавиатуры, запустить программу Paint (Пуск – Программы – Стандартные - Paint) и в меню Правка выбрать Вставить. Полученный снимок следует аккуратно обрезать и сохранить в формате gif в личной папке.

    3.4. Отчет о лабораторной работе

    Отчет о работе должен содержать титульный лист, цель и задачи работы, снимки экрана с полученными переходными характеристиками апериодического звена и выводы. Выводы следует сформулировать в техническом, а не в методическом стиле. Например: "Построена и исследована модель, в результате чего установлено, что переходная характеристика апериодического звена представляет собой…". Не следует формулировать вывод в форме "В результате работы мы научились …". Современный язык технических отчетов требует использования безличной формы изложения.

    Заключение

    Работа выполнена. Знакомство с интерфейсом состоялось, построена и исследована простая модель, что позволило уяснить принцип моделирования в программном комплексе "МВТУ". Производит впечатление то, что программа быстро выполняет огромную работу за человека, оставляя ему творческую, исследовательскую сторону моделирования.

    Контрольные вопросы.

    1. Поясните принцип построения модели в ПК "МВТУ".
    2. Что такое графический интерфейс программы?
    3. Назовите основные элементы главного окна ПК "МВТУ".
    4. Назовите основные вкладки Палитры блоков ПК "МВТУ".
    5. Как запустить новый проект? Как открыть созданную ранее модель?
    6. Как вынести блок на рабочее пространство окна модели?
    7. Как соединить выход одного блока и вход другого?
    8. Какая передаточная функция у апериодического звена?
    9. Как выглядит переходная функция апериодического звена? Ее формула.
    10. Как определить параметры апериодического звена (коэффициент усиления и постоянную времени) по его переходной характеристике?
    11. Как поменять цвет кривой на виртуальном осциллографе?
    12. Как изменить заголовок графика?
    13. Как сохранить файл модели? Какое расширение имеет этот файл?
    14. Как сформулировать выводы по работе в техническом, а не методическом стиле?

    Литература и ссылки.

    1. ЯДЕРНЫЕ РЕАКТОРЫ
    2. "МВТУ" - программный комплекс для моделирования и исследования систем и объектов (сайт http://www.reactors.narod.ru/mvtu/mvtu.htm )
    3. "МВТУ" - программный комплекс для моделирования и исследования систем и объектов (сайт http://energy.power.bmstu.ru/mvtu/ )
    4. Лукас В.А. Теория автоматического управления. – М.: Недра, 1990. – 416 с.
    5. Сайт кафедры автоматизации технологических процессов и производств Рудненского индустриального института (Казахстан)
      http://web.host.kz/atpp

        6. Приложение:

        Файл проекта (образец) Perech_Ap_Zv.mrj

        Рудный, 2003 г.

        Далее >>


"MBTY": Программый комплекс для моделирования и исследования объектов и систем

Федосов Б.Т.

Лабораторная работа №2

"МВТУ"
Знакомство с инструментами частотного анализа
систем управления

Содержание

  1. Цель и задачи работы
  2. Модель САР и ее частотные характеристики
    • 2.1. Построение модели
    • 2.2. Подготовка модели к проведению ее частотного анализа
    • 2.3. Оценка устойчивости разомкнутой САР по критерию Михайлова
    • 2.4. Оценка устойчивости замкнутой САР по критерию Найквиста
    • 2.5. Коррекция САР с использованием логарифмических частотных характеристик
      • 2.5.1. Порядок построения ЛАЧХ и ЛФЧХ
      • 2.5.2. Косвенная оценка качества САР
      • 2.5.3. Структурная коррекция САР
      • Определение настроечных параметров ПИ-регулятора
      • Модификация схемы
      • Косвенная оценка качества САР с ПИ-регулятором
      • Оценка качества скорректированной САР
  3. Задание и методические указания по выполнению и оформлению работы
    • 3.1. Построение модели
    • 3.2. Подготовка модели к проведению ее частотного анализа
    • 3.3. Проверка устойчивости разомкнутого контура САР по критерию Михайлова
    • 3.4. Оценка устойчивости замкнутой САР по критерию Найквиста
    • 3.5. Коррекция САР с использованием логарифмических частотных характеристик
    • 3.6.Оформление отчета
  • Заключение
  • Контрольные вопросы
  • Литература и ссылки
  • Приложения

1. Цели и задачи работы

Цель работы: освоение порядка построения частотных характеристик системы автоматического регулирования (САР) и их краткий анализ.

Задачи работы:

  • построение модели САР третьего порядка и подготовка ее для проведения частотного анализа;
  • построение годографа Михайлова (годографа характеристического полинома разомкнутой САР);
  • построение годографа Найквиста (годографа комплексного коэффициента передачи разомкнутой САР);
  • построение логарифмических частотных характеристик разомкнутой САР;
  • структурно-параметрическая коррекция САР.

2. Модель САР и ее частотные характеристики

Частотные характеристики линейной САР позволяют косвенно судить о ее качестве. Более того, эти характеристики позволяют оптимизировать параметры и структуру САР для получения требуемых ее свойств. Частотные характеристики представляют в той или иной форме зависимость коэффициента усиления системой синусоидального сигнала от частоты этого сигнала. Анализируя частотные характеристики системы можно установить степень ее устойчивости и определить меры для ее стабилизации. Анализ частотных характеристик проводится с помощью критериев устойчивости Михайлова и Найквиста.

Ниже проведено рассмотрение способов построения частотных характеристик и их анализа на примере САР третьего порядка, наиболее простой из САР, способных терять устойчивость. Поскольку цель работы прежде всего состоит в освоении инструментов ПК "МВТУ" , пример выбран так, чтобы большинство настроек сохранялось по умолчанию, с тем, чтобы легче было ухватить общую идею работы с инструментами и создать базу для изучения нюансов и подробностей.

2.1. Порядок построения модели

В качестве примера выберем очень простую одноконтурную схему системы автоматического регулирования частоты вращения вала двигателя постоянного тока (рис.1).

Рис. 1. Модель САР частоты вращения вала двигателя постоянного тока (ДПТ). П-регулятор и тиристорный преобразователь моделируются апериодическим звеном, а двигатель – колебательным звеном.

Назначение рассматриваемой САР – поддержание частоты вращения вала двигателя в соответствии с величиной задающего воздействия, поступающего на устройство сравнения системы регулирования. Для изучения характеристик САР, на нее в данном случае подается сравнительно сложный для восприятия, быстро меняющийся в нулевой момент времени ступенчатый сигнал. Можно считать, что если система удовлетворительно отследит этот быстрый сигнал, то при работе в реальных условиях, когда большую часть времени на нее поступают плавные сигналы, качество слежения, т.е. поддержания требуемого значения частоты вращения, будет еще лучше.

Контур моделируемой САР включает в себя П-регулятор, тиристорный преобразователь и двигатель постоянного тока. Для упрощения модели в данном случае П-регулятор объединен с тиристорным преобразователем, так, что они совокупно моделируются апериодическим звеном с коэффициентом усиления, равным произведению их коэффициентов усиления. Двигатель постоянного тока (ДПТ) моделируется колебательным звеном, влияние возмущений на работу ДПТ в данном учебном примере не рассматривается. В обратной связи реальной САР установлен тахогенератор - датчик частоты вращения вала. Это безинерционное пропорциональное звено, которое мы отнесем к ДПТ, скорректировав его коэффициент усиления, с тем, чтобы сделать обратную связь единичной. Т.о. схема приведена к типовому виду [3] рис.1. Апериодическое звено можно рассматривать как обобщенную модель регулятора, а колебательное звено – как объект управления.

Построение модели.

Порядок вынесения блоков в окно модели и их соединения вам известен из первой лабораторной работы. При желании можно убрать обрамление блоков, выбрав в главном меню МВТУ Опции – Настройки , убрав галочку в пункте Рисовать обрамление и щелкнув по кнопке Да.

В дополнение к тем блокам, которые уже рассматривались в лабораторной работе 1, в схеме рис.1 установлен блок сравнения (Сравнивающее устройство) с вкладки Операции Палитры блоков. Этот блок вычисляет сигнал ошибки, т.е. разность между сигналом задания, поступающим слева, и выходным сигналом колебательного звена, пропорциональным частоте вращения вала двигателя.

На схеме рис.1 появился еще один новый элемент – ветвление. После того, как выход колебательного звена подключен к входу осциллографа, от этой линии следует сделать ответвление к нижнему входу сравнивающего устройства. Это требует определенной сноровки и навыка. Один из простых способов проведения линии состоит в следующем. Необходимо, все время удерживая нажатой клавишу Ctrl щелкнуть по линии правой кнопкой мыши. На линии появится точка. Продолжая удерживать Ctrl, щелкнуть по точке левой кнопкой мыши. Курсор примет вид прицела. Продолжая удерживать клавишу Ctrl, перемещать курсор к точкам поворота линии, где щелкать левой клавишей. Продолжать действия вплоть до подключения линии к входу блока, после чего отпустить клавишу Ctrl. С течением времени это операция не будет встречать затруднений, но на первом этапе, если линия получится неудачной, ее можно удалить, щелкнув по ней правой клавишей и выбрав в выпавшем меню Удалить линию в связи (Ctrl+Del).

Рис. 2 (анимация). Порядок создания ветвления и проведения линии связи. На всем протяжении операции следует удерживать нажатой клавишу Ctrl. По исходной линии следует сначала щелкнуть правой кнопкой, по возникшей точке и в углах поворота создаваемой линии следует щелкать левой кнопкой мыши. Анимацию можно остановить щелчком по кнопке Стоп в верхней части браузера, а запустить вновь – щелчком по кнопке Обновить.

Далее следует задать значения коэффициентов усиления блоков регулятора и двигателя. Дважды щелкнув по апериодическому звену, введем в появившемся окне коэффициент усиления 2.1 и щелкнем Да (рис. 3).

Рис. 3. Диалоговые окна для установки значений параметров апериодического и колебательного звеньев.

Аналогичную операцию проделаем с колебательным звеном, убедимся, что его коэффициент усиления равен 1 и нажмем Да.

Схема построена, параметры введены. Остается дважды щелкнуть по блоку осциллографа в окне модели, переместить появившееся окно графика в правую часть экрана и подравнять его размеры так, как показано на рис.4.

Запустить модель, щелчком по кнопке Пуск (Продолжить расчет) – бегущий человечек.

Рис. 4. Исходная схема САР и график ее переходной функции.

Как видно на рис.4, заданные значения коэффициентов усиления и других параметров, оставленных по умолчанию, привели к устойчивой системе, но переходная функция стремится к стационарному значению со значительным переколебанием.

Рис. 5 (анимация). По мере увеличения коэффициента усиления апериодического звена, а значит и всего контура, переходная функция становится все более колебательной и в итоге система теряет устойчивость: размах свободных колебаний при неизменном входном сигнале становится все больше с течением времени.

Увеличение коэффициента усиления приводит к ухудшению устойчивости системы и одновременно улучшает качество ее в установившемся режиме. Задача проектировщика найти здесь разумный компромисс.

2.2. Подготовка модели к проведению ее частотного анализа

Для проведения частотного анализа модели нужно указать, какие ее звенья будут подвергнуты такому анализу. Для этого следует отметить условный вход анализируемого фрагмента схемы и его условный выход. В данном случае условным входом будет вход САР, а условным выходом – ее выход.

В программном комплексе "МВТУ" условный вход и условный выход обозначают с помощью блока В память, расположенном на вкладке Субструктуры (рис.6). Два таких блока следует вынести на окно модели и присоединить к входу и к выходу САР. Двойным щелчком по блоку, присоединенному ко входу САР вызвать окно задания названий переменных и изменить название Y1 на более содержательное: Вход. Переменную Y2 назвать Выход аналогичным образом. Для украшения схемы введем поясняющие надписи к этим блокам. Щелчком правой кнопки по левому блоку вызовем меню, выберем Свойства и на вкладке Общие введем поясняющую надпись sin(wt), что напомнит о том, что частотный анализ проводится с использованием гармонического сигнала, частота которого изменяется в некоторых пределах. Аналогично, для правого блока запишем A*sin(wt+fi), что поясняет то, что линейная система изменяет амплитуду и начальную фазу синусоидального сигнала, на нее подаваемого и эти изменения зависят от частоты.

Рис. 6. Указание условных входа и выхода анализируемого фрагмента схемы с помощью двух блоков В память с вкладки Субструктуры. Обратная связь, условно показанная желтым цветом, изображена на схеме, но фактически отсутствует, поскольку весовой коэффициент по нижнему входу устройства сравнения задан равным нулю (см. рис.7), т.о. контур САР разомкнут. Переходная функция разомкнутой САР монотонно и асимптотически стремится к своему максимуму. Следовательно, разомкнутый контур устойчив.

Отметим, что в соответствии с критериями устойчивости частотному анализу должна быть подвергнута разомкнутая САР. Особенность ПК "МВТУ" в том, что он проверяет, все ли входы и выходы соединены и если это не так, то не позволяет проводить моделирование. Поэтому не всегда можно разорвать обратную связь удалением соединительной линии. В данном случае можно просто установить коэффициент веса сравнивающего устройства по нижнему входу равным нулю. Для этого следует дважды щелкнуть по устройству сравнения в окне модели и в появившемся окне заменить второй весовой множитель с -1 на 0 (рис.7).

Рис. 7. Для размыкания контура первый весовой множитель устройства сравнения оставлен равным 1, а второй задан равным нулю.

Схема подготовлена для частотного анализа.

Примечание. Для наглядного изображения размыкания и замыкания обратной связи может применен блок Ключ управляемый с вкладки Палитры блоков Ключи – см. приложение П1.

2.3. Оценка устойчивости разомкнутого контура САР по критерию Михайлова

На рис. 6 по графику переходной функции хорошо видно, что разомкнутый контур устойчив. Поэтому проверка его устойчивости по критерию Михайлова проводится здесь только с методической целью изучения порядка проведения этого исследования в "МВТУ" . Отметим, что в маловероятном случае, когда не возможно получить непосредственно переходную функцию разомкнутого контура, необходимость обеспечения его устойчивости может потребовать применения именно критерия Михайлова. Необходимость же проверки устойчивости разомкнутого контура диктуется условием практического применения критерия Найквиста, который в свою очередь необходим для оценки устойчивости замкнутого контура и выработки мер по его стабилизации.

В главном меню МВТУ Анализ выбрать Частотный анализ. Появляется окно Параметры частотного анализа, в котором следует щелкнуть по кнопке Создать окно Годографов. Это добавит в окно нижнюю часть (рис.8):

Рис. 8. Окно задания параметров частотного анализа для построения годографа Михайлова (годографа характеристического полинома разомкнутой САР).

Методом проб и ошибок в окне рис.8 подбирается значение конечной частоты так, чтобы на графике можно было бы видеть какие квадранты, и в каком порядке проходит годограф. Остальные значения установить такими, какие показаны на рис. 8.

Щелкнуть по кнопке Годограф Михайлова в окне Параметры частотного анализа. Немедленно появляется окно с годографом:

Рис. 9. Годограф характеристического полинома разомкнутой САР третьего порядка проходит три квадранта в положительном направлении. Разомкнутая САР устойчива.

В нашем случае удачное задание значения конечной частоты в 3 рад/сек позволяет увидеть, что годограф начинается на действительной оси в точке (1, 0j) и при увеличении частоты последовательно проходит против часовой стрелки три квадранта. Увеличение конечной частоты не выводит годограф из третьего квадранта. В соответствии с критерием Михайлова такая система устойчива, что впрочем, мы и так знаем из рис. 6.

Окно рис. 9 может потребовать подбора его параметров и цвета линии. Для этого следует щелкнуть правой кнопкой по окну и применить Автомасштаб, если график не виден, или выбрать Свойства и задать такие значения концов осей координат и число делений, чтобы масштабы осей стали одинаковыми. Кроме того, здесь же задается название годографа и цвет линии.

Нетрудно доказать, что последовательное соединение конечного числа устойчивых звеньев устойчиво. Поскольку разомкнутая САР состоит из двух устойчивых звеньев, то она структурно устойчива. Это значит, что при любом сочетании параметров апериодического и колебательного звеньев годограф характеристического полинома будет начинаться на действительной оси и последовательно проходить против часовой стрелки три квадранта. Тем не менее, существуют и неустойчивые системы третьего порядка, например замкнутая САР рис. 4 при коэффициенте усиления контура 8.4 (рис.5). В этом случае, годограф характеристического полинома замкнутой САР (годограф Михайлова) начинается на действительной оси, из первого квадранта сразу переходит в четвертый, а потом в третий квадрант (рис. 10):

Рис. 10. Годограф характеристического полинома неустойчивой САР. Состояние САР близко к границе устойчивого и неустойчивого режимов работы: годограф проходит вблизи начала координат.

Как видно на рис.5 и рис. 10, при коэффициенте усиления контура, равном 8.4, замкнутая САР неустойчива, и находится близко к границе устойчивого и неустойчивого режимов работы.

Итак, если указан фрагмент схемы, для которого следует построить годограф Михайлова, то вся процедура построения сводится к четырем щелчкам левой кнопкой мыши: Анализ – Частотный анализ – Создать окно Годографов - Годограф Михайлова. При необходимости можно добавить Автомасштаб, щелкнув правой кнопкой по графику.

2.4. Оценка устойчивости замкнутой САР по критерию Найквиста

Полезную работу выполняет замкнутая САР, она-то и должна быть устойчивой. Годограф комплексного коэффициента передачи разомкнутой САР позволяет с помощью критерия Найквиста судить не только о факте, но, косвенно, и о степени устойчивости замкнутой САР. По этому годографу можно определить косвенные параметры качества: запасы устойчивости САР по амплитуде и по фазе.

Убедитесь, что обратная связь САР в схеме рис. 6 разомкнута: второй весовой коэффициент устройства сравнения (по нижнему входу) должен быть равен 0 (рис. 7). Проверьте и при необходимости установите исходное значение коэффициента усиления апериодического звена равное 2.1. Сделайте контрольный запуск модели, с тем, чтобы переходная функция имела вид, показанный на рис. 6.

Выберете Анализ – Частотный анализ – появится окно Параметры частотного анализа, в котором следует выбрать пункт Создать окно Годографов. Появятся окно годографов, которое временно нужно убрать на задний план, а на передний вызвать окно Параметры частотного анализа, рис. 8. В нем следует выбрать построение годографа Найквиста. Для этого нужно щелкнуть в окне Параметры частотного анализа по кнопке с красным плюсом +, в результате чего в нижнем поле появится нумерованная строка с номером 1. Щелкнуть по синей графе Входы и в появившемся окне выбрать переменную Вход, введенную нами ранее в блоке В память, определившем начало фрагмента анализируемой схемы (рис. 6). В следующей графе Выходы аналогичным способом выбрать переменную Выход. В последней графе выбрать Найквиста (рис. 11).

Рис. 11 (анимация). Задание входной и выходной переменных, определяющих фрагмент схемы, для которого будет построен годограф и выбор типа годографа – годограф Найквиста.

Остается щелкнуть по кнопке Расчет в окне Параметры частотного анализа и через короткое время годограф будет построен. При конечной частоте 3 рад/сек (рис.11) годограф слегка не дошел до начала координат, поэтому изменим значение конечной частоты на 100 и вновь щелкнем по кнопке Расчет. Оформим внешний вид окна, в частности сделаем одинаковыми масштабы осей. Результат на рис. 12.

Рис. 12. Годограф комплексного коэффициента передачи разомкнутого контура САР с дополнительной прорисовкой. Выделена точка (-1, 0j). Если годограф не охватывает эту точку, как в данном случае, замкнутая система устойчива. Отметим, что для правильной оценки запаса по фазе, масштабы осей должны быть одинаковыми.

Точка А на рис. 12 соответствует значению комплексного коэффициента передачи W(jω) на частоте ωπ. Частота, на которой модуль коэффициента передачи равен единице называется частотой среза ωср.

Как видно на рис. 12, анализируемая САР имеет хорошие запасы устойчивости по амплитуде 1/ОА=1/0.25= 4 раза = 12 дБ и по фазе γ= 720. Это свидетельствует о том, что в переходном режиме качество САР будет вполне удовлетворительным. В то же время, коэффициент усиления контура равен k = 2.1= 6 дБ, что косвенно говорит о низком качестве работы моделируемой САР в установившемся режиме. Эта величина должна составлять для статической системы 20 ÷ 40 дБ. Отсюда следует, что для обеспечения удовлетворительного качества работы системы необходима структурная коррекция исходной САР, которая может быть осуществлена введением ПИ-регулятора в контур управления.

2.5. Коррекция САР с использованием логарифмических частотных характеристик.

Логарифмические частотные характеристики содержат ту же информацию, что и годограф комплексного коэффициента передачи, но представлена она в ином виде, что в ряде случаев упрощает анализ свойств системы и выбор мер по ее коррекции. ЛАЧХ и ЛФЧХ могут, как и годограф комплексного коэффициента передачи, анализироваться с позиций критерия Найквиста.

Преимущество "МВТУ" по сравнению, например, с программой того же класса VisSim, состоит в том, что частотные характеристики выводятся в одном и том же окне при изменении параметров схемы. Это упрощает оформление отчета, особенно электронного.

2.5.1. Порядок построения ЛАЧХ и ЛФЧХ

Порядок построения ЛАЧХ и ЛФЧХ в ПК "МВТУ" прост и состоит в следующем. Для модели рис.6 в главном меню ПК "МВТУ" выбрать: Анализ – Частотный анализ, в окне Параметры частотного анализа выбрать Создать окно Характеристик, перевести на передний план окно Параметры частотного анализа, в котором появилось внизу поле выбора анализируемого фрагмента схемы. Дважды нажать кнопку +, в нижнем поле появятся две нумерованные строки, в которых следует указать, щелкая по соответствующим графам, названия переменных Вход и Выход, а также для первой строки выбрать ЛАХ, а для второй ФЧХ (см. рис. 13). Остается щелкнуть по кнопке Расчет и получить график с характеристиками:

Рис. 13. Задание фрагмента схемы для проведения частотного анализа указанием названий соответствующих переменных, и вида требуемых характеристик. Справа показаны графики ЛАЧХ и ЛФЧХ, выдаваемые ПК "МВТУ" при щелчке по кнопке Расчет.

2.5.2. Косвенная оценка качества САР

Полученные графики могут быть масштабированы иным образом для упрощения анализа (рис. 14):

Рис. 14. Изменения масштабов графиков позволяет более подробно увидеть поведение ЛФЧХ – левый рисунок и более точно (правый график) определить запасы устойчивости по фазе и амплитуде, которые в данном случае составляют: по фазе γ=720 и по амплитуде L=12 дБ, что согласуется со значениями, полученными на рис. 12 по годографу комплексного коэффициента передачи. Усиление на нижних частотах (коэффициент усиления разомкнутого конура) 6 дБ – недостаточно, качество статической САР в установившемся режиме будет низким.

Для упрощения просмотра и анализа ЛФЧХ целесообразно выбирать шаг разметки оси ординат равным 150, 300, 450 или 900, так, чтобы была видна линия -1800. ЛАЧХ удобнее анализировать при шаге разметки в 20 дБ или кратном этому значению.

Качество любой статической САР, конкретный вариант которой рассматривается здесь в примере, при присущем ей быстродействии удовлетворительно, если выполняются три условия:

  1. запас по фазе находится в пределах 400 ÷700 и более;
  2. запас устойчивости по амплитуде находится в интервале 6 ÷ 12 ÷ 20 дБ и
  3. коэффициент усиления контура равен 20 ÷ 40 дБ.

Изменением коэффициента усиления контура всегда можно выполнить первое и второе условия, но одновременно выполнить и третье удается не всегда.

Как видно на рис. 14, в рассматриваемой системе выполняются только первые два условия. Это говорит о том, что качество САР при работе в установившемся режиме будет неудовлетворительным. Увеличением усиления контура можно попробовать выполнить третье условие, но при этом значения запасов уменьшаются ниже допустимого минимума. Поэтому для коррекции данной системы в контур следует ввести ПИ-регулятор.

Отметим, что быстродействие САР характеризуется временем регулирования, примерно равным утроенному значению обратной величины 1/ωср частоты среза ωср, частоты на которой ЛАЧХ пересекает ось частот (абсцисс). В данном примере будем считать, что полученное быстродействие устраивает заказчика системы, и не будем его корректировать.

2.5.3. Структурная коррекция САР
Определение настроечных параметров ПИ-регулятора

Простая методика определения его настроечных параметров для случая, когда выполнены первое и второе условия (см. 2.5.2), предлагается ниже. Передаточную функцию ПИ-регулятора запишем в виде:

Для удобства построения следует изменить масштаб графика с тем, чтобы можно было более крупно видеть участок ЛАЧХ, на котором ее наклон изменяется с 0 дБ/дек на -20 дБ/дек, и было бы удобно строить линии с наклоном -20 дБ/дек. Далее следует провести касательные к ЛАЧХ с наклонами 0 дБ/дек и -20 дБ/дек. Точка пересечения касательных дает частоту сопряжения, обратную к искомой постоянной времени Тр ПИ-регулятора (рис. 15).

Рис. 15. Определение постоянной времени Тр ПИ-регулятора.

На рис. 15 видно, что lg(1/Тр )= - 0.39, поэтому 1/Тр= 0.4, следовательно Тр=2.5 сек. Начальное значение коэффициента усиления k ПИ-регулятора следует взять равным 0.5. При необходимости эту величину можно будет уточнить по виду результирующей переходной функции замкнутой САР, но, как правило, это значение удачное. Т.о. передаточная функция ПИ-регулятора для рассматриваемой САР примет вид:

В ПК "МВТУ" коэффициенты полиномов линейного блока общего вида (W(s) Общего вида) с вкладки Палитры Динамические вводятся в порядке возрастания степеней, поэтому преобразуем передаточную функцию ПИ-регулятора к виду:

Сохраним проект в личной папке под именем Frq_Char_PI_Reg.mrj, с тем, чтобы коррекцию осуществлять в новом проекте.

Модификация схемы

В схеме рис.6 освободим место для вставки блока ПИ-регулятора: увеличим размер окна модели, сдвинем вправо блоки апериодического, колебательного звеньев и осциллографа, уберем некоторые подписи блоков, удалим линию связи от устройства сравнения к апериодическому звену, куда будет вставлен ПИ-регулятор. Подравняем линии связей, при необходимости заменяя их на новые.

В качестве ПИ-регулятора в данном примере для простоты будет использован линейный блок общего вида, хотя ПИ-регулятор может быть реализован и другими способами. Итак, вынесем на рабочее пространство окна модели линейный блок ( W(s) Общего вида ) с вкладки Палитры Динамические блоки и соединим его с устройством сравнения и апериодическим звеном. В результате будет получена схема рис. 16:

Рис. 16. Скорректированная схема разомкнутой САР частоты вращения вала двигателя постоянного тока. Разомкнутая обратная связь условно показана желтым цветом. Ввиду наличия интегратора в контуре переходная характеристика разомкнутой системы линейно и неограниченно растет с течением времени.

Далее следует установить значения коэффициентов полиномов линейного блока с тем, чтобы его передаточная функция приняла вид (3). Для этого нужно дважды щелкнуть по блоку и в появившемся окне ввести коэффициенты в порядке возрастания степеней (рис. 17):

Рис. 17. Задание коэффициентов линейного блока общего вида с тем, чтобы он выполнял функции ПИ-регулятора. Во второй строке на первом месте стоит ноль и через пробел введен коэффициент 2.5 члена первой степени, что в совокупности соответствует интегратору.

Щелкнуть по кнопке Да.

Косвенная оценка качества САР с ПИ-регулятором

Качество переходного режима астатической САР косвенно характеризуется запасами устойчивости по амплитуде и фазе.

Запустить работу модели щелчком по кнопке с бегущим человечком. Поскольку ПИ-регулятор структурно содержит интегратор, переходная функция разомкнутой САР после окончания переходного процесса линейно изменяется с течением времени (рис. 16).

Построим ЛАЧХ и ЛФЧХ разомкнутого контура скорректированной системы: Анализ – Частотный анализ и в окне Параметры частотного анализа выберем Создать окно Характеристик, щелкнем по кнопке Расчет (см. рис. 13). В результате появится окно с графиками, которому можно придать вид:

Рис. 18. ЛАЧХ и ЛФЧХ скорректированной САР. Запас устойчивости по фазе составляет 740, а по амплитуде 12 дБ. На нижних частотах ЛАЧХ идет с наклоном -20 дБ/дек, а ЛФЧХ близка к -900. Это обусловлено наличием в контуре управления интегратора, являющегося составной частью ПИ-регулятора.

Как видно на рис. 18, все требования к косвенным параметрам качества астатической САР выполнены, следовательно можно ожидать, что качество скорректированной САР будет по крайней мере удовлетворительным.

Сделать снимок окна ЛАЧХ и сохранить его в личной папке. Щелкнуть по кнопке Да в окне Параметры частотного анализа, частотные характеристики будут убраны с экрана.

Оценка качества скорректированной САР

Остается проверить качество переходного режима скорректированной замкнутой САР. Для этого следует замкнуть обратную связь введением второго весового коэффициента устройства сравнения равного -1. Дважды щелкнуть по устройству сравнения в окне модели и в появившемся окне заменить второй весовой множитель с 0 на -1 (рис.19). Щелкнуть по кнопке Да.

Рис. 19. Замыкание обратной связи САР установкой второго весового коэффициента компаратора (устройства сравнения) равным -1.

Запустить процесс моделирования кнопкой Пуск с бегущим человечком. Будет построена переходная характеристика замкнутой скорректированной САР. После уточнения масштаба и времени интегрирования (кнопка (Параметры счета F10) главной панели "МВТУ" ) схема и переходная характеристика примут вид:

Рис. 20. Схема скорректированной САР и ее переходная характеристика. Время регулирования составляет 4 сек при перерегулировании в 6 %. Качество скорректированной САР вполне удовлетворительное.

Установившееся значение переходной функции равно 1.0 – значению входного сигнала. Это значит, что ошибка САР в установившемся режиме при отслеживании постоянного сигнала равна нулю. Таким образом, в результате введения в контур управления ПИ-регулятора система приобрела астатизм первого порядка.

3. Задание и методические указания по выполнению работы

С разрешения преподавателя запустить ПК "МВТУ" .

3.1. Построение модели

Постройте в соответствии с п. 2.1 модель замкнутой САР частоты вращения вала двигателя постоянного тока рис.1, определите ее переходную функцию, соотнесите с рис. 4. Дополните схему и окно осциллографа содержательными надписями. Обрамление блоков, при желании, можно убрать, выбрав в главном меню "МВТУ" Опции – Настройки, убрав галочку в пункте Рисовать обрамление и щелкнув по кнопке Да.

Проверьте, как влияет изменение коэффициента усиления апериодического звена на вид переходной функции замкнутой системы.

В качестве дополнительного задания, по выполнении основной части работы, можно проверить, как влияет изменение коэффициента усиления контура на установившееся значение ошибки регулирования. Для этого может быть использован либо еще один осциллограф, который следует подключить к выходу устройства сравнения, либо в имеющемся можно добавить еще один вход. Из этого исследования можно сделать вывод о том, что увеличение коэффициента усиления контура приводит к уменьшению установившегося значения ошибки, но время установления увеличивается ввиду повышения колебательности переходного процесса.

Сделайте выводы.

Верните исходное значение коэффициента усиления апериодического звена, равное 2.1 и для контроля еще раз запустите модель на счет.

Сделайте снимки экрана, сохраните проект в личной папке с названием Frq_Char.mrj

3.2. Подготовка модели к проведению ее частотного анализа

Обозначьте вход и выход анализируемого фрагмента схемы (рис.6), разомкните обратную связь установкой нулевого значения второго весового коэффициента компаратора (устройства сравнения) в соответствии с п.2.2 (рис.7).

Сделайте снимки экрана, сохраните проект.

3.3. Проверка устойчивости разомкнутого контура САР по критерию Михайлова

Постройте годограф характеристического полинома разомкнутой САР (годограф Михайлова) в соответствии с п.2.3 и по критерию Михайлова определите, устойчива ли разомкнутая САР. Сравните результат с тем, что следует из вида переходной характеристики разомкнутой САР, полученной в п.3.1 (рис. 6). Сделайте выводы.

Сделайте снимки экрана, сохраните проект.

3.4. Оценка устойчивости замкнутой САР по критерию Найквиста

Постройте годограф комплексного коэффициента передачи разомкнутого контура (годограф Найквиста) в соответствии с п. 2.4. Используя критерий Найквиста, определите, будет ли устойчивой замкнутая САР. Определите запасы устойчивости САР по амплитуде и фазе. Сделайте выводы.

Сделайте снимки экрана, сохраните проект.

3.5. Коррекция САР с использованием логарифмических частотных характеристик

Сохраните предыдущий проект в личной папке под новым названием Frq_Char_PI_Reg.mrj. Это позволит начать выполнение этого пункта сначала, если в процессе коррекции возникнут непредвиденные затруднения (вдруг да повиснет программа в результате каких-то неправильных действий :-)). По этой причине рекомендуется периодически сохранять сделанную работу.

Постройте ЛАЧХ и ЛФЧХ разомкнутой САР в соответствии с п.2.5. Определите запасы устойчивости по амплитуде и фазе, соотнесите их с результатами, полученными в п.3.4.

Скорректируйте САР введением ПИ-регулятора, определите по ЛАЧХ оптимальное значение постоянной времени ПИ-регулятора. Постройте результирующие ЛАЧХ и ЛФЧХ и переходную функцию скорректированной САР. Соотнесите результаты с рис. 20. Сделайте выводы.

Сохраните проект, сделайте снимки экрана и также сохраните в личной папке.

3.6.Оформление отчета

Отчет должен содержать титульный лист, цели и задачи работы, результаты выполнения разделов работы, включая снимки экрана со схемами и частотными характеристиками, выводы.

Заключение

В работе построена и исследована хоть и простая, но «настоящая» модель системы автоматического регулирования. При этом было использовано всего семь видов типовых блоков. Таких блоков в ПК "МВТУ" порядка ста, что позволяет моделировать и сложные, многоуровневые системы управления, объекты различной физической природы. Для этого нужно постепенно освоить применение этих блоков, но принцип построения и исследования модели уже ясен.

Как видно из проделанной работы, программный комплекс "МВТУ" обладает мощными и простыми в использовании инструментами, позволяющими исследователю проводить частотный анализ систем управления. Оформленные графики не только дают информацию о системе, но и отвечают требованиям технической эстетики, украшая отчеты.

Контрольные вопросы

  1. Что такое частотные характеристики линейной системы?
  2. С какой целью в ПК "МВТУ" указываются входная и выходная переменные при частотном анализе САР?
  3. Как провести соединительную линию между блоками?
  4. Как создать ветвление соединительной линии?
  5. Как в ПК "МВТУ" построить годограф Михайлова для линейной системы?
  6. Как в ПК "МВТУ" построить годограф Найквиста для линейной системы?
  7. Как в ПК "МВТУ" построить ЛАЧХ и ЛФЧХ линейной системы?
  8. Вопрос на сообразительность: как на рисунках годографов проставить значения частот соответствующие некоторым его точкам, например с шагом в 5 рад/сек?

Литература и ссылки

    1. ЯДЕРНЫЕ РЕАКТОРЫ
    2. "МВТУ" - программный комплекс для моделирования и исследования систем и объектов (сайт http://www.reactors.narod.ru/mvtu/mvtu.htm)
    3. Лукас В.А. Теория автоматического управления. – М.: Недра, 1990. – 416 с.
    4. "МВТУ" - программный комплекс для моделирования и исследования систем и объектов (сайт http://energy.power.bmstu.ru/mvtu/ )
    5. Сайт кафедры автоматизации технологических процессов и производств Рудненского индустриального института (Казахстан)
      http://web.host.kz/atpp

    Приложения:

    П1. Полезный блок: Ключ управляемый.

    Наглядность схемы повышается, если для размыкания обратной связи использовать Ключ управляемый с вкладки Ключи Палитры блоков (рис. П1).

    Рис. П1 (анимация). Управляемый ключ позволяет видеть его состояние и менять его на обратное двойным щелчком по блоку. Как видно, переходные характеристики САР в замкнутом и разомкнутом состоянии существенно отличаются.

    П2. Файлы проектов:
    Построение годографов:
    Frq_Char.mrj
    Коррекция САР:
    Frq_Char_PI_Reg.mrj
    Ключ в обратной связи:
    Key_In_Loop.mrj

    Рудный, 2003 г.

    К лабораторной работе №1 >>


Fedosov B.T. Федосов Б.Т. RII, Kazakhstan

Об авторе

Автор методического руководства

Приятное знакомство:
"МВТУ"
 программый комплекс для моделирования и исследования
объектов и систем

Федосов Борис Трофимович
доц. Рудненского индустриального института
Казахстан
Служебная страница
http://web.host.kz/atpp/fed.htm